Yamaha FZ-09 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Here's the story: lately I'm having trouble starting the bike. I need to keep cranking for 5 seconds or so and it finally starts. It doesn't happen all the time, maybe once every 10 starts. After one difficult start like this, the check engine icon wouldn't go away. I start riding and I could feel the engine got rougher. I could feel vibrations I didn't have before. At idle my mirrors vibrate, something that never happened before. Generally the engine vibrates more than before, no matter what speed or gear.

I took it to Yamaha telling them the problem with difficult start and the check engine. They said the relay had some errors, replaced the relay and gave the bike back. I still have intermitent problems starting it and the vibration is still there.

I would appreciate any thoughts.
 

·
Registered
Joined
·
400 Posts
I'd take back again...
 

·
Registered
Joined
·
610 Posts
Yep. Take it back.
 

·
Super Moderator
Joined
·
5,762 Posts
I'm going to add.....Take it to a Dealer........just NOT the first one you took it to!
 
  • Like
Reactions: Lee Drew

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
Do your mirrors vibrate at idle? Maybe I'm just crazy ...
 

·
Registered
Joined
·
1,152 Posts
Running on two cylinders? Check plugs if you want to DIY.
 

·
Registered
Joined
·
4,649 Posts
Absolutely no mirror vibes at idle on mine. They're both rock solid.
 
1 - 9 of 9 Posts
Top