Yamaha FZ-09 Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Hey everyone, been working on the bike a little here and there for the past week so I thought I’d share. Started off with the intention of just removing the evap canister and sending the ECU off for a reflash, but that quickly changed.

I had a few things sitting around I’ve been waiting to install so I decided what better time than now?!

XSR900 bars
162881

Koso Apollo heated grips
162882

wired into the auxiliary connector
162883

Horn relocation
162884

Waiting on a package with blockoff plates to finish up here
162885

Next I’m going to be mounting these LED pods, I’ll probably do a more detailed install so pictures to come!
162886
 

·
Registered
Joined
·
155 Posts
The first gen models have an aux port plug and play for heated grips?

I thought it was only the newer models.

I wanted to instlal fogs on my bike but looks like i will have to do some electrical work.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #3
The first gen models have an aux port plug and play for heated grips?

I thought it was only the newer models.

I wanted to instlal fogs on my bike but looks like i will have to do some electrical work.
Yeah I was under the impression it was only the second gen, but when I was disassembling to get the ecu out I noticed the plug.
 

·
Registered
Joined
·
155 Posts
Can you show me a pic of where exactly it is? Not sure where i'm looking at in the picture. Also is it in the right or left side scoop. I have a 2014.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
Can you show me a pic of where exactly it is? Not sure where i'm looking at in the picture. Also is it in the right or left side scoop. I have a 2014.
Gray connector underneath the right side scoop. Its wedged between the black connector to its right and the plastic shroud, but I pulled it out for the picture. All you need is the pins for the wires and some wire rubber seals.
162887
 

·
Registered
Joined
·
290 Posts
When those block off plates show up you might have a bit of a hard time getting at the bolts. I pulled the top mounting bolts on the radiator so it could fall forward and that gave me enough room to get my ratchet in there. You may or may not need to do this but figured I'd let you know in advance!
 

·
Registered
Joined
·
51 Posts
Have you tried your heated grips yet? That connector is only on a 5 amp fuse if I remember correctly. The wires are not big enough for heated grips. Your probably going to find that it will pop the fuse when you turn them up to high. They did on mine anyway.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #10
When those block off plates show up you might have a bit of a hard time getting at the bolts. I pulled the top mounting bolts on the radiator so it could fall forward and that gave me enough room to get my ratchet in there. You may or may not need to do this but figured I'd let you know in advance!
Thanks for the tip man! They arrive tomorrow so I'll definitely pull those radiator bolts.
I think that connector is only 2amp not the 5amp you need for the grips.
For the Koso is it not a 2A draw? I remember reading 2A, but now I can't find it anywhere.
Have you tried your heated grips yet? That connector is only on a 5 amp fuse if I remember correctly. The wires are not big enough for heated grips. Your probably going to find that it will pop the fuse when you turn them up to high. They did on mine anyway.
Not yet! I had to get a new battery which I did, but the tank is strapped down over the rear while I do everything else lol
 

·
Registered
Joined
·
80 Posts
Discussion Starter #11
If I remember right, Oxford grips draw 4A, but Koso is only 2A.
Feel free to correct me if I'm wrong though lol
 

·
Registered
Joined
·
785 Posts
IIRC, the '17 and up have two aux power plugs, one on each side. One is 2A, the other is 5A.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #13
Test fit the LED pods last night. Gonna bring them up and back toward the forks a little more. ECU arrives today so hopefully within the next few days I can get things assembled back together to be able to power them on.
162894

162895
 

·
Registered
Joined
·
80 Posts
Discussion Starter #16
ECU just arrived from vcyclenut, as well as a k&n filter and Graves block off plates so now I have everything I need to start putting everything back together. Spring semester of the last stretch of my senior year just started so I’ll have to wait till the weekend.
162898
 

·
Registered
Joined
·
717 Posts
Are you going to modify your airbox too?
I personally haven't done that yet myself.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #18
Are you going to modify your airbox too?
I personally haven't done that yet myself.
Yeah that’s probably the last thing I’ll do. I plan on following vcyclenuts instructions. Gonna do something a little different, but I’ll post some pictures when it’s done!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #19
Update...

Installed the Graves block off plates and freshly flashed ECU from vcyclenut last night so I could finally power up the bike to test everything.

A bit of background - ever since I got the bike it would never start on the first try. Failed the battery load test and I also read the evap canister could cause a similar issue. Since the bike was apart I removed the evap canister and threw in a new battery. Bike starts like a dream now and just sounds crisp overall. Supposed to have clear, 60* weather this weekend so I'm gonna try to get it back together to be able to do a shakedown ride.

162917


Colorclusterz LCD flip + orange
162918


Still need to finish the brackets for the pods, but they are extremely bright!
162919
 

·
Registered
Joined
·
80 Posts
Discussion Starter #20
Also, does anyone know why the Graves block off plates kit has two rubber caps? They're different sizes so I know it's not a spare. One caps off the outlet on the left side of the airbox which is shown in the instructions, but they don't mention the other one.
 
1 - 20 of 29 Posts
Top