Yamaha FZ-09 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hey guys,
just curious. I got a set of the TST led front and rear turn signals, and the quick wire sets (plus the flasher module). I did a quick watch on the install, just to make sure I was good on how it goes on this bike (2016 FZ09) and I swear that the guy in the video said that with the TST turn signals and easy wire sets, you would not have the running lights working. Well after getting mine on, I used heat shrink over the connections instead of electrical tape, used the same color wires the guy in the video used,and I have running lights on and yes, my flashers work fine..Any ideas? Again, my bike is a 2016, did I miss something? Was the guy in the video wrong?


Sean
 

·
Vendor
Joined
·
772 Posts
If you keep filament bulbs in the rear they can work as running/signals. If you switch to led signals in the rear they will not work anymore as running lights.

If you want some signals you can see as running lights and signals get these.

2013+ FZ 07/09 Proton Signals

If you want your current led signals to function as running/signals you can get this.

Electronic 3 wire to 2 wire signal converter
 

·
Registered
Joined
·
114 Posts
The TST lights on my 2016 also work as front park and turn signals. I used there connectors and relay also and followed the same diagram as you. For the rear I have the motodynamic integrated tail light. Have been using for over a year with no problems.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
Yeah I think it because I have my stock rears for the moment. Havent taken the back end apart yet to add the leds...
 

·
Registered
Joined
·
101 Posts
Tripage #2 post is on point. Once you wire up the rear LED, the front running lights will not work. Happened to me as well. I had to re wire the front lights so they would work properly with LED all around.
 

·
Registered
Joined
·
10 Posts
I bought the TST Industries MECH-GTR Front LED Turn Signals and they look great and are very bright, I just installed them. No instructions in the box neither but it was pretty simple. I am now willinf to know if any of you bought some rear flush mount signals to integrate them (drilling holes) in the rear fairing to avoid having them on the fender eliminator, as it looks better imo. Any of you did that ? I'd like to see pictures of how it looks and which model of signals were bought. Thank you.
157169
157170
 

Attachments

1 - 8 of 8 Posts
Top