Yamaha FZ-09 Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1 (Edited)
After patiently waiting for the release of TST's new MECH-GTR front turn signals I am happy to report they were well worth the wait. Very pleased with the overall look and brightness of the SMD LED. Anyone else get them yet?

Having a hard time uploading pictures unfortunately..
 

·
Registered
Joined
·
201 Posts
I was on vacation at a music festival called Bonnaroo over the weekend it was released and missed out. Waiting for them to come back in stock.
 

·
Registered
Joined
·
44 Posts
Same - I missed the release (though sadly not because I was at Bonnaroo) and am now waiting for them to get another batch in stock. Will likely be putting my Protons up for sale once I get the Mech-GTRs.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4 (Edited)
I procrastinated but I finally signed up for the email alert for when they became available. Ordered them while having my morning coffee before work and when I checked that evening they were unavailable already.
 

·
Registered
Joined
·
14 Posts
I ordered them first thing the morning they were released. Had them installed 2 days later. Had an issue with the ratcheting retainer rings holding them but TST sent me new ones and they're perfect now. I love them! The design is spot on with the theme of the bike.
 

·
Registered
Joined
·
201 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #10
Couple hundred miles in and no issues. Still extremely happy with them especially for the price. I will be adding Rizoma "Action" rear signals to my TST fender eliminator soon. They also are single SMD LED's.
 

·
Registered
Joined
·
13 Posts

·
Registered
Joined
·
201 Posts
TST just emailed me and let me know they got a dozen clear and a dozen smoked in stock just now.

I ordered mine.

(I had a coupon code specific to me so I had to order through TST)

Just FYI.
 

·
Registered
Joined
·
6 Posts
Has anyone had issues with these? I'm wondering if it's just the latest batch...

I got mine 2 days ago and the mounts are loose - one doesn't stay on at all and the signal gradually falls out. Even the one that stays on isn't very tight and the signal vibrates around. TST is sending new ratchet clip things so we'll see if there's any improvement.

I also feel like the wiring was shorter than shown in the video - I routed the wiring on my throttle side (2017) straight down from behind the tank and there's still no slack in the line once the scoop is installed. On top of that, there's visible wires coming from the back of the signals. Maybe it's nitpicking but I just expected more given the price point - I'm kind of wishing I'd just saved $40 and bought cheapo LED's that mount securely and spliced in the longer stock signal wires.
 

·
Registered
Joined
·
201 Posts
Has anyone had issues with these? I'm wondering if it's just the latest batch...

I got mine 2 days ago and the mounts are loose - one doesn't stay on at all and the signal gradually falls out. Even the one that stays on isn't very tight and the signal vibrates around. TST is sending new ratchet clip things so we'll see if there's any improvement.

I also feel like the wiring was shorter than shown in the video - I routed the wiring on my throttle side (2017) straight down from behind the tank and there's still no slack in the line once the scoop is installed. On top of that, there's visible wires coming from the back of the signals. Maybe it's nitpicking but I just expected more given the price point - I'm kind of wishing I'd just saved $40 and bought cheapo LED's that mount securely and spliced in the longer stock signal wires.
I'm having the same problem with one of mine. I need to contact them.

I already had an issue where the wires broke on the little running light module. Those inline resistors are a bad design.

It's a shame because I love the design of these.
 

·
Registered
Joined
·
201 Posts
Good news @fazerade,

I reached out to TST and they have an updated mounting peice. It's a nylon clip with a rubber o-ring. They are sending a pair to me at no cost.

Here is their response to me:
"We’ve recently received some o-rings we are testing that can be installed behind the fairing/shroud on the signal and then the ratcheting lock can be tightened down on the o-ring. This kit will be exclusive to 2017+ FZ-09 owners as the signal shroud is slightly thinner than the other FZ/MT line models."

Reach out to them and see if they'll get you one as well!
 

·
Registered
Joined
·
14 Posts
Has anyone had issues with these? I'm wondering if it's just the latest batch...

I got mine 2 days ago and the mounts are loose - one doesn't stay on at all and the signal gradually falls out. Even the one that stays on isn't very tight and the signal vibrates around. TST is sending new ratchet clip things so we'll see if there's any improvement.

I also feel like the wiring was shorter than shown in the video - I routed the wiring on my throttle side (2017) straight down from behind the tank and there's still no slack in the line once the scoop is installed. On top of that, there's visible wires coming from the back of the signals. Maybe it's nitpicking but I just expected more given the price point - I'm kind of wishing I'd just saved $40 and bought cheapo LED's that mount securely and spliced in the longer stock signal wires.
I had the exact same issues. They sent me older white ones but they worked better. I had short wires too which I couldn’t route the way in the video. I just routed my own way and wrapped the wires carefully in electrical tape and they don’t show now.
 

·
Registered
Joined
·
117 Posts
Looks like i need to email them too. Mine are loose even with the ratchet ring clicked all the way down. They look good though!!
 
1 - 20 of 29 Posts
Top