Yamaha FZ-09 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter · #1 ·
I am trying to get my LED turn signals working as both running lights and signals, and I bought the tripage 3 wire converters seen here: 3 wire to 2 wire signal converter

It seems like a simple concept, 2 red wires, 1 black wire, black=ground red wires can go to either running light wire or turn signal wire, shouldn't matter. It doesn't come with instructions.

When I wire it up, the signals are just always on like running lights, they do not flash. A voltage tester shows that all 3 wires are working properly, 1 always on, 1 flashing, 1 ground

I have tried it on both sides left and right, same result. I have tried it with incandescent bulb and LED bulb, same result. A voltage tester on the 2 wire side shows a constant 12 volts, no change.

Am I doing something wrong? Ideas?
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #3 ·
Well, that's weird, but someone asked me if I had the led flasher relay, and their post disappeared. Anyway, I have a LED flasher relay installed, the signals blink when wired normally, but when using this tripage mod they just stay on all the time, no flashing at all.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #5 ·
I appreciate that, but I already knew of that product and decided against it. With certain wiring techniques you can emulate the blinker genie for free anyway, the tripage thing is supposed to function differently as I understand, it should have a dim light for running light and flash brighter, similar to OEM, where the blinker genie just kills the light temporally to make it flash.

I've messed around with it for over an hour, I'll see if they answer the phone tomorrow.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #6 ·
After talking to Tristan today, it seems that his product is not compatible with the FZ-09. It requires that the running light, which is 12v constant, turns off when the signal is on. Which the FZ-09 apparently does not do. The blinker genie works as a normally closed relay, and really seems to be the only option. The other wiring option I mentioned results in a weak ground and dim bulb.
 

·
Registered
Joined
·
55 Posts
There has to be a relay in the stock bulb fixture to cause it to blink maybe you could take it apart and reuse it somehow
 

·
Registered
Joined
·
11 Posts
After talking to Tristan today, it seems that his product is not compatible with the FZ-09. It requires that the running light, which is 12v constant, turns off when the signal is on. Which the FZ-09 apparently does not do. The blinker genie works as a normally closed relay, and really seems to be the only option. The other wiring option I mentioned results in a weak ground and dim bulb.
I have the same problem 2016 XSR900 . The front indicators only function as DRL after installing the 2 to 3 from Tripage. I already have a 2 prong flasher from TST. WHAT IS THW SOLURION TO GET THE FRONT LEDS TO FLASH ? Tripage markets there product specifically for the FZ09 and now I’m hearing it doesn’t work? Seems redundant to add a blinker Henie to my TST flasher. Help a brother out
 

·
Registered
Joined
·
1,537 Posts
I have the same problem 2016 XSR900 . The front indicators only function as DRL after installing the 2 to 3 from Tripage. I already have a 2 prong flasher from TST. WHAT IS THW SOLURION TO GET THE FRONT LEDS TO FLASH ? Tripage markets there product specifically for the FZ09 and now I’m hearing it doesn’t work? Seems redundant to add a blinker Henie to my TST flasher. Help a brother out
You’re judging whether or not the product works on a post that’s 6 years old. I have Tristans 3-2 wire conversion on my ‘14 09...same wiring as your XSR and it works fine. Make sure it’s wired correctly, and you have the correct relay for LED’s. Without knowing your exact situation or how they’re wired, can’t provide more info for you. But if you can’t find the solution, just call or email Tristan...he’s really good about replying to emails....
 

·
Registered
Joined
·
1,148 Posts
Off topic... but i have a couple of these in my garage and no longer have the bike. if anyone wants a couple shoot me a message.
 
1 - 10 of 10 Posts
Top