Yamaha FZ-09 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hello everyone, newbie to the forum here! Excuse my English, I’m Dutch.

I got myself a 2014 FZ09 and installed a GPR Furore slip-on exhaust. I didn’t really push it hard the first week because I needed to get used to the bike. However, now that I’m comfortable, I do notice some torque loss (mostly in second gear). Especially when comparing it to my friend’s fz09. It’s not a huge difference but when I full throttle his one in second gear the front comes up bigtime. Mine not even a bit, I just get launched (very hard).

The exhaust’s description says no need for a remap (there’s a small cat in there and a db-killer). I kinda still wanna do a flash or something just to get that bit back. Do you guys think a flash would fix my issue, or do you think the issue might be elsewhere?

Thanks in advance!

Danny
 

·
Vendor
Joined
·
1,863 Posts
congrats on the new bike!

It doesnt have to have a flash as in it is not going to blow up if you do not get one but that doesnt mean it will run optimal. The bike doesnt run optimal with the stock pipe and stock ecu.

The stock ecu leaves the bike lean at part throttle, opening up the exhaust exacerbates this. This is why you are experiencing a lack of throttle response in the mid range

The flash will fix it and make it better then it was before you installed the exhaust

ton of info on the site, check it out and let me know any questions you have

2014-2020 MT/FZ/FJ-09/XSR900/GT 900 tracer custom flash (vcyclenut.com)
 

·
Registered
Joined
·
6,246 Posts
A flash is a good idea, but your test is not exactly scientific. A loss of torque would be more noticeable in higher gears.
 
  • Like
Reactions: dannyajc
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top