Yamaha FZ-09 Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #21 (Edited)
im being told by Graves they reached out today to you and took care of it and you are happy with the answer.

they also pulled all the other stock to make sure it wasn't affected and that your end pipe didn't have the correct step up in case any one else is worried they will be affected by it

Thanks David!

Yes they contacted me first thing this morning via email. At first they were going to send me a new silencer, but later in the day they said they were going to send me a new tail pipe. They think that the pipe didn't get the correct step-up. Got the shipping info this afternoon and Graves sent the piece 2 day air ( which was nice).

I'm happy that they are communicating with me and the new videos appeared to be helpful. Think I've learned a little bit about how to show visually what my concerns are.

I do believe that since it was forwarded from David it was taken a little bit more seriously, but I can't verify that this is true. Just my impression.

David has been a class act to work with everything else I've got including my flash, quick shifter, block off plates were grade A. David provide excellent information and communication through the whole process. I would gladly work with him again and wouldn't hesitate one iota to order anything from him.

I'm holding my final opinion of Graves for the resolution of my issues. We'll find out Wednesday or Thursday if the answer we come to in fact solved the problem.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #22
I took another look at the video of the install posted above. Paying particularly close attention to the end of the pipe that meets the silencer. In the video you can see where the pipe has been expanded on the end (stepped up). Well I can confirm that the tail pipe I received did not have this step up. So I have great hope that the new pipe I'm being sent will correct the problem. I guess I've learned something new about how exhaust fit together.
 

·
Registered
Joined
·
3 Posts
I took another look at the video of the install posted above. Paying particularly close attention to the end of the pipe that meets the silencer. In the video you can see where the pipe has been expanded on the end (stepped up). Well I can confirm that the tail pipe I received did not have this step up. So I have great hope that the new pipe I'm being sent will correct the problem. I guess I've learned something new about how exhaust fit together.
 

·
Registered
Joined
·
3 Posts
I had a problem with the clearance on my pipe too. Although mine didn't have any play it still was poorly positioned.
 

·
Registered
Joined
·
151 Posts
Hey all,

Just ordered a Graves full titanium exhaust with a carbon fiber silencer from vcyclenut. I attempted the install which seemed like it should have been fairly straight forward. However, there is allot of play in the can where it can touch both the swingarm and the rear sets. I called Graves and they have seemed less than interested in helping me resolve the issue. I've taken everything thing apart and reinstalled them times with no success. To me it feels like there is to much play in the joint between the can and mid pipe. However, maybe my exhaust mount is bad and needs replaced. I really can not think of any other reason for this problem. I think I my try to swap the rubber mount from the other side. I took a pretty crummy video that I got to try to attach. The bikes is in some at another location so I'll have too try to get a better video. Any thought or suggestions would be appreciated!
The two pictures show how much movement is possible and why is vibrating against the swing arm.

Crummy video
What year FZ09 do you have? I have a 14 with full Graves exhaust and I don’t have ant issues with it.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #26
It's a 2018. The exhaust in question is currently on it's way back to Graves.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #27
I had a problem with the clearance on my pipe too. Although mine didn't have any play it still was poorly positioned.
It's a tight clearance where the can is supposed to sit. It doesn't take more than a mm here or there to give it too much play. Mine was positioned right just too much lateral movement. After speaking to Graves on the phone and them viewing the videos they agree. So the parts are going back. They've doing everything to make it right. I'm giving them that opportunity, I'll update when I get the new parts.
 
21 - 27 of 27 Posts
Top