Yamaha FZ-09 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi, I have a question and your help is greatly appreciated !!! The bike is 2017 XSR900

Oil light comes on and off after oil change when I push the bike a little bit, but not all the time. Oil level is at 3/4. The manual says use 10W40 or 10W50 JASO MA. Since the summer has come in Vegas already I have switched from 10W40 to 10W50 for the hot weather, but is JASO MA2. I have wonder if that might be a problem, but it shouldn't. I have read for the same problem on different forum, but only one person has replied to the post " OIL level should be to the max border line" - witch doesn't sound right to me. I have had 11 bikes for 10 years and did lot's of oil changes always at 3/4 level and never experienced this problem before. Does anybody have an advice?

Thank you in advance!
 

·
Registered
Joined
·
1,000 Posts
As with most yamahas it is a level sensor, put more oil in as the cp3 motor is quite sensitive to oil levels.
^ agreed. I've seen a few threads these past couple of months on this topic. Conclusion is just that possibly you didn't have the bike "perfectly" vertical and ended up under filling per the site glass just a smidge. And yes these bikes have an oil level sensor (not pressure) so it's just thinking you're a bit low.
 

·
Registered
Joined
·
1,380 Posts
Put 3 qts in after every oil and filter change. You will never see the light again.

Sent from my SM-G950W using Tapatalk
 

·
Registered
Joined
·
24 Posts
My last bike (FZS1000/FZ1 to you septics) had to be filled to the top of the sight glass otherwise the oil light would flicker under hard braking/acceleration
 

·
Registered
Joined
·
626 Posts
Thank you guys, seems like everybody is on the same page, I will fill it up.
Yep, the very top of the sight glass is the FULL line. That's where I run mine and I never see an oil level warning light. JASO MA2 has nothing to do with it.
 
1 - 7 of 7 Posts
Top