Yamaha FZ-09 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
So me front LED running lights and blinkers came in this week so I tried this morning to hook them up..... To start the 09 has 3 stock wires (green, blue, black) and my LEDs have two! (Yellow, black) they claim to be plug and play but I tried and my front head light went out and my blinkers won't flash?? Any advice or help would be great!
 

·
Registered
Joined
·
1,806 Posts
did they come with the yamaha oem turn signal connectors already attached, or did you have to wire them up yourself?

ultimately you want the yellow wire on the signals to connect to the dark brown wire on the wiring harness for the left signal, and green for the right. black goes to black. if that still doesn't work, try swapping the yellow and black.

headlight doesn't come on until the engine's running.
 

·
Registered
Joined
·
4,498 Posts
The blue OEM wire is for the running lights. If you do not have a blinker genie, you will omit the blue wire, delete the running lights, and have turn signals only.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
It came with adapters that didn't fit the stock harness so I had to wire around it. Thanks for the help guys! Ill try your suggestions and see if it works out!
 

·
Registered
Joined
·
4,498 Posts
FWIW, no aftermarket signals come with OEM connectors, really, except in my experience Watsens. They all say "plug and play"... But really, how do they know what bike those signals will end up on... Even the Yamaha aftermarket signals do not come with the OEM connectors, LOL

Watsens only do because they are custom made, one set at a time. Each set is made for one customer.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
Is it possible I blew a fuze messing with it? They won't blink, turn on, brighten for hazard, NOTHING. tail running lights won't even work... Any tips?
 

·
Registered
Joined
·
418 Posts
FWIW, no aftermarket signals come with OEM connectors, really, except in my experience Watsens. They all say "plug and play"... But really, how do they know what bike those signals will end up on... Even the Yamaha aftermarket signals do not come with the OEM connectors, LOL

Watsens only do because they are custom made, one set at a time. Each set is made for one customer.
I SERIOUSLY hope Watsens make some for the FZ! I have them on my R1 and they are awesome! Anything is comparision is complete garbage!
 

·
Registered
Joined
·
277 Posts
I SERIOUSLY hope Watsens make some for the FZ! I have them on my R1 and they are awesome! Anything is comparision is complete garbage!
They do, it'd be the same as for the FZ1 and FZ6. They have been very limited on availability to order though...they opened up for about 3 days in March to order, I put two sets on order then and those aren't going out until April or May most likely. The wait is killer, but what you get is a very high quality product.
 
1 - 11 of 11 Posts
Top