Yamaha FZ-09 Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
So I'm out on my bike at bike night and noticed when leaving I have a tail light but no brake light. Where is the relay and I've already checked fuse's. Help!!!!
 

·
Registered
Joined
·
4,424 Posts
Did you try your back brake? If you have put on Steel brake lines and aftermarket levers, it may be that the lever trigger needs trimming.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Nope it worked on the way here. Neither front and rear operate the brake light. And with my c average electrical skills I managed to kill the running lights too. Headlight and tail light still light up.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
So what is not working is the turn signal running light, self induced, turn signals work. And my break light, running light is ok but no bright brake light.
 

·
Registered
Joined
·
151 Posts
back when I adjusted the height of my brake pedal I did not realize for two days that my rear brake light was "engaged" the whole time. There is a separate adjuster that triggers the brake light. Perhaps your brake light is running and you think it is just the rear red running light. It took some trial and error to get it right but I'm sure someone around here can properly describe how to fix it for you.

Also, from what I recall the rear signals do not operate as running lights. Only the front.

Either way, glad you made it home safe.
No brake light is not a good thing.. but if you ride safely and do not panic, getting home should not be an issue. Seems like you freaked out a little bit out there on the road. Just my opinion, but definitely good to reach out here. This forum can solve any FZ-09 problem!
 

·
Registered
Joined
·
111 Posts
Are you sure your brake light is not on all the time ?

Most times the rear brake light switch needs adjustment as it keeps the brake light on.

Because the front and rear use different switches it could only be a wire or globe but I'm still betting on the the rear switch being to tight and holding the light on.

Disconnect the spring that pulls the rear switch and see if you get brake lights to work from your front brake ?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Nah not as much freaked out as pissed/upset lol. I'll inspect the rear brake adjustments and make sure my peddle didn't drop on the way out but my buddy remembered seeing the brake light on the ride in.

And can anyone clarify that the rear turn signals are not on at all times when the key is on? I'm like 99% sure their supposed to be on.
 

·
Registered
Joined
·
1,536 Posts
Nah not as much freaked out as pissed/upset lol. I'll inspect the rear brake adjustments and make sure my peddle didn't drop on the way out but my buddy remembered seeing the brake light on the ride in.

And can anyone clarify that the rear turn signals are not on at all times when the key is on? I'm like 99% sure their supposed to be on.
The rear signals act only as signals-the taillight is your rear running light. Constant on for vehicle running lights in the US is amber front and red rear...If your signals work front and rear and your amber running lights are lit up front, and the outer two rows of LED's are lit in the rear, it sounds as if it may be brake switch related. If it was a fuse, none of your tail light would be lit.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
Well the adjustment of the brake levers wasn't it, ohm'd it out and both switches are open until pulled/pushed
Where is the relay for the brake lights?

And ok so my rear turn signals DO NOT act as running lights and should always be off unless 4-ways or turn signals are on

Correct?
 

·
Registered
Joined
·
1,242 Posts
correct, the rear signals are direction indicators only, and do not function as "running lights" at all. so turn signals yes, hazard lights yes, running lights no.
 

·
Registered
Joined
·
239 Posts
Well the adjustment of the brake levers wasn't it, ohm'd it out and both switches are open until pulled/pushed
Where is the relay for the brake lights?

And ok so my rear turn signals DO NOT act as running lights and should always be off unless 4-ways or turn signals are on

Correct?
:cool:That is correct. Two Options you might consider when all is well: Blinker Genie for Run and Turn with LED Signals on Motorcycles ? Custom LED and http://www.fz09.org/forum/13-fz-09-...ts-led-taillight-integrated-turn-signals.html

Hope all is well soon.
:cool:

Slow response due to looking up 2 options
 

·
Registered
Joined
·
40 Posts
Do you get power on the rear connector when you hit the brake? One wire will be hot all the time (running light), the other only hot with the brake on.
 

·
Registered
Joined
·
192 Posts
I'm installing the tail tidy kit by r&g n now my brake light, is not working at all. Could it be a ground issue? Any help?
 

·
Registered
Joined
·
192 Posts
Check your fuses man. I blew out mine and it acted similar when i was replacing the front signals. Check all the fuses.
I only found 2 red 10 amp fuses under the seat and they where fine, can you guide me to where are the other fuses located, also why would that fuse blow out of no where? Is it because I disconnected the tail light during the install? :dontknow::dontknow::dontknow:
 

·
Registered
Joined
·
50 Posts
the side panel on the front of the bike is where mine was that was blown out. check with your owners manual for a picture of it. the cover just pops off its on there with rubber grommets
 

·
Registered
Joined
·
192 Posts
Thanks man, I will look through my manual. Hope it's as simple as this, installing a tail tidy won't void the bike warranty, would it?
 
1 - 20 of 24 Posts
Top