Yamaha FZ-09 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
Wanted to let you all know my experience with the Graves LED turn signals. I purchased these a couple weeks ago and finally got around to installing them. I ordered two sets (four signals total) at $99 a pair so all in all around 200 bucks. This price was kind of hard for me to swallow but given how they are advertised as "plug & play" I figured I would go for it. First thing I noticed out of the box was that one of the four signals was distinctively more yellow tinted than the others. This was screw up number 1. Decided to power on anyway.

image5.jpg

Screw up number 2: I installed the rear pair first. It quickly became apparent that the "plug & play" wires were way too short and needed extending. Graves' website states, "Rear marker lights can be used with either the stock fender (stock fender required manually extining the wire length) or Graves Motorsports Fender Eliminator Kit" I have the Yoshimura fender kit that looks to put the signals in a similar position as the Graves' kit. But again the wire was too short and required extending at least 6 inches.

Screw up number 3: After installing the rear lights and confirming that they did indeed blink I set off to work on the front pair of signals. The good news was installation was super easy and quick. The bad news was after turning the bike on all 4 signals and the signal indicator on the dash stayed permanently lit. At this point I'm getting pretty frustrated with my $200 purchase.

image1.jpg

Screw up number 4: I triple check all my wiring to no avail and in a final act of desperation call Graves Motorsports customer service. The guy on the other end of the phone almost immediately tells me I need to buy CustomLED's $20 LED turn signal relay. His explanation had something to do with the electrical current being different on every FZ-09 they had tested and that this $20 turn signal relay would solve my problem. So a few days later I receive my turn signal relay. And, like before, all the signals are lit all the time. No blinking. At this point I figure it has something to do with the third running light wire in each of the front turn signals. I take the front apart again and cut out those wires. Huzzah! Working turn signals for the first time. They look good minus the one that is more yellow then the others and they are somewhat / kind of / barely visible in direct sunlight.

image6.jpg
image3.jpg
image7.jpg

Long story short, don't be an idiot like me and buy 2 pairs of these turn signals from Graves Motorsports. I spent $220 bucks on this crap. As I was writing this review I've noticed the signals are now priced at $129 a pair. Total rip off! I should have just been patient and waited for the Watsen Design LEDs. Lesson learned the hard way.
 

·
Registered
Joined
·
857 Posts
Good review, sorry for the bad news, but thanks for sharing.

Ride Safe
 

·
Super Moderator
Joined
·
5,734 Posts
Nice write up/review. Sorry to hear that they weren't what you were hoping for and you aren't thrilled with them. I'm going to move this over to the Vendor Review/Links section in an effort to keep things a bit more organized.
 

·
Registered
Joined
·
1,370 Posts
That sucks, but what I've found with any bike is that the electrical systems do run slightly different on each bike. I have this same Graves light, mine plugged right in and started working. Mine stay on when the bike is running and are evenly lit. The only downside is like you said, not as bright in the daylight and the dash light stayed on dimly. At night, these lights look fantastic.

I've seen allot of posts like this and allot where they work just fine. I did have a similar experience like yours with a set of Rizoma's once on the FZ-09. Its hit and miss I suppose with any bike and turn signal combination.

The good thing is you found something that works and I bet if you sell these to someone else they might have better luck with them.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
That sucks, but what I've found with any bike is that the electrical systems do run slightly different on each bike. I have this same Graves light, mine plugged right in and started working. Mine stay on when the bike is running and are evenly lit. The only downside is like you said, not as bright in the daylight and the dash light stayed on dimly. At night, these lights look fantastic.

I've seen allot of posts like this and allot where they work just fine. I did have a similar experience like yours with a set of Rizoma's once on the FZ-09. Its hit and miss I suppose with any bike and turn signal combination.

The good thing is you found something that works and I bet if you sell these to someone else they might have better luck with them.
I hear ya. At night they do look really good. My main gripe is the 200 dollar price tag combined with the fact that they are advertised as plug and play. I guess it says something favorably that I'm not willing to go through the process of taking them off and returning them.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,370 Posts
I went through 4 different sets of LED's on my Ducati before I found some that actually worked. Last thing I wanted to do is mess with electrical system by installing a relay on an old Italian bike. Went through the same process on my old GSXR too. The Rizomas I was installing was for another forum member on here trying help him out.. luckily on my FZ-09 I lucked out with the Graves blinkers first time around.
 

·
Registered
Joined
·
610 Posts
Thats how Graves affords to have his play toys built for him.

Wanted to let you all know my experience with the Graves LED turn signals. I purchased these a couple weeks ago and finally got around to installing them. I ordered two sets (four signals total) at $99 a pair so all in all around 200 bucks. This price was kind of hard for me to swallow but given how they are advertised as "plug & play" I figured I would go for it. First thing I noticed out of the box was that one of the four signals was distinctively more yellow tinted than the others. This was screw up number 1. Decided to power on anyway.

View attachment 13312

Screw up number 2: I installed the rear pair first. It quickly became apparent that the "plug & play" wires were way too short and needed extending. Graves' website states, "Rear marker lights can be used with either the stock fender (stock fender required manually extining the wire length) or Graves Motorsports Fender Eliminator Kit" I have the Yoshimura fender kit that looks to put the signals in a similar position as the Graves' kit. But again the wire was too short and required extending at least 6 inches.

Screw up number 3: After installing the rear lights and confirming that they did indeed blink I set off to work on the front pair of signals. The good news was installation was super easy and quick. The bad news was after turning the bike on all 4 signals and the signal indicator on the dash stayed permanently lit. At this point I'm getting pretty frustrated with my $200 purchase.

View attachment 13311

Screw up number 4: I triple check all my wiring to no avail and in a final act of desperation call Graves Motorsports customer service. The guy on the other end of the phone almost immediately tells me I need to buy CustomLED's $20 LED turn signal relay. His explanation had something to do with the electrical current being different on every FZ-09 they had tested and that this $20 turn signal relay would solve my problem. So a few days later I receive my turn signal relay. And, like before, all the signals are lit all the time. No blinking. At this point I figure it has something to do with the third running light wire in each of the front turn signals. I take the front apart again and cut out those wires. Huzzah! Working turn signals for the first time. They look good minus the one that is more yellow then the others and they are somewhat / kind of / barely visible in direct sunlight.

View attachment 13313
View attachment 13314
View attachment 13315

Long story short, don't be an idiot like me and buy 2 pairs of these turn signals from Graves Motorsports. I spent $220 bucks on this crap. As I was writing this review I've noticed the signals are now priced at $129 a pair. Total rip off! I should have just been patient and waited for the Watsen Design LEDs. Lesson learned the hard way.
 
1 - 7 of 7 Posts
Top