Yamaha FZ-09 Forum banner

101 - 110 of 110 Posts

·
Registered
Joined
·
357 Posts
Mine keeps going up with milage and it averages 47-51 with hard starts and wheelies. I use Rotella T6 full synthetic, M4 slip on, 2015 reflash, and no wind screen. Also 220 with gear and tire pressure is what it came with from dealer/manual.
 

·
Registered
Joined
·
12 Posts
Yeah, I didn't get the remap that Yamaha is offering under warranty, yet. I get around 52 mpg if I keep it under 75. Thats the hard part. I ride in STD or B moslty, when riding with friends. When I'm alone its a different story and my mpg goes down alot. Can't keep the speed down :) But i have taken a bunch of weight off and runiing pilot road 3's. The OEM Bridgestones were done at 4000. I do wish the tank was bigger. I came off my trusty 2001 Kawi ZR7s with a 5.8 gallon tank and 55 plus carburated motor.
 

·
Registered
Joined
·
276 Posts
Discussion Starter #103
Well I got really great gas mileage today. We rode for a few hours in the twisties and then on the way home on the highway we were getting over 50mpg at 80mph (the computer was registering about 51-52mpg on the straight/level highway at 80mph sustained speed). I think it is a mixture of the modified Puig touring screen, 10% taller gearing, harder compound rear tire, oil having 1500+ miles on it (thins out with age), and having the bike very warm. We weigh 215 pounds between us. I'm probably going to add a couple inch lip to the top of the screen. If I can avg 50+ on the highway at 80-85mph I will be happy. In the twisties and around town is a different story, I usually get between 38-43mpg avg.
 

·
Registered
Joined
·
1,949 Posts
I got just over 100 miles on my bike. Flat terrain riding, but quite a variety of speeds and throttle. My "average" is reading 51.7. I assume that's good, but again this is an 847cc bike.
 

·
Registered
Joined
·
19 Posts
Hey DNFDOUG, my fuel bars do the same thing. It holds at full till about 75miles then stays at 4 and 3 for a long time too. It will sometimes show 3 bars when I shut off the bike then be at one when I start up. I've had the pump replaced (under warranty) and still does the same. Anyone else having this issue? It's completely unreliable but I'm used to watching miles not gauges so not a prob, but still burns that a brand new Yami can't get this simple task right!
 

·
Registered
Joined
·
1,058 Posts
See post #25 in this thread. Mine wll also show two bars when parked, then one bar when started cold and then a second bar appears when the bike warms up.
 

·
Registered
Joined
·
383 Posts
Howdy. I took my fz09 across the country. 5000 miles round trip. I never once ran out of gas and I was in the middle of nowhere. 1 1.5 liter fuel bottle and a 1 liter mtn dew bottle filled with gas. Never had to use either. Wouldn't worry about running out of gas between stations when touring.
 
101 - 110 of 110 Posts
Top