Yamaha FZ-09 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

long story short, I had an autotuner installed and I'm removing it now. The problem is, when putting back my factory o2 sensor... I threw away all of the old wiring and I can't for the life of me figure out where it connects to.

I have attached a few pictures, the o2 wire connects from the muffler to a missing connection on the left of the engine case. From there it goes up underneath the tank and connects to the ECU. Can anyone tell me the part numbers for the wire and harness that connects the o2 sensor to the ecu? If not, can anyone post some pictures of this area on a stock bike? I can reverse lookup the part if I know what I'm looking for.

All of the part diagrams neglect this harness... I have spoke with several companies and they are lost.

Also.. second part. If it connects to the emissions part that then connects to where the block off plates are (Little black pump looking thing) then I have a technical question I need assistance with. If I have block off plates installed... ?? What do I do then to connect my factory o2 sensor?

Thanks!
 

Attachments

·
Registered
Joined
·
857 Posts
It connected to the wiring that was thrown away. I looked at Partszilla, the parts diagram is sketchy and doesn't show everything. Wiring harness assembly is only $460. Sure you didn't tuck the extra wire out of the way and forgot? You would have had to cut the connector off.

Good luck.
 
1 - 3 of 3 Posts
Top