Yamaha FZ-09 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all,
Stupid me also connected battery backwards.
After replacing burned fuses (50A main and 7.5A ETV) the bike still doesn’t start.
Anyone has any idea/experience what should I expect? Burn
I can post the video but:
  • screen turns on
  • I hear the fuel pump
  • it’s only cranking, doesn’t start

Notes:
  • the kill switch was engaged when it briefly happened
  • I checked all fuses under the seat and right side air scoop
-the battery is ok and it didn’t start also when trying with a car battery
 

·
Registered
Joined
·
783 Posts
Yep, same here, I had to replace a 7.5amp fuse. Mine would start, but would run stupid rough. I replaced this 7.5amp fuse and bam... Hooliganism again baby! ( yep, installed battery backwards too ) 🤦‍♂️
 

·
Registered
Joined
·
6 Posts
Hi guys, I did the same thing, new battery had reversed polarity to the old one and I accidentally installed it backwards. Bike blew the 50AMP fuse. Now I replaced the fuse, bike turns on, check engine light is one, fuel pump primes and and starter cranks but the bike wouldn't start. I would appreciate any advice (and potential location of other burned fuses)
 

·
Premium Member
Joined
·
3,241 Posts
Hey Lebowski, you could find out from Mela but I'm pretty sure he's dead to us.
When you get it fixed please check back in and let us know what you did.
 

·
Registered
Joined
·
6 Posts
Hey Lebowski, you could find out from Mela but I'm pretty sure he's dead to us.
When you get it fixed please check back in and let us know what you did.
Actually, this morning I had more time to look at the bike (yesterday i was doing it in the dark with phone flashlight) and I found that 7.5AMP ETV fuse was blown too. I replaced it and bike has started. Looks like that was it. Check engine light is still on.
 

·
Registered
Batmobile
Joined
·
1,085 Posts
You'll have to have the light cleared, I did the same thing a while back. There's no problem, just doesn't like being dead. I ended up buying a cable to go from the yamaha connector on ebay and an OBD2 to Bluetooth device. I can monitor all my sensors via the torque pro app now too. I'll see if I can find the links.
 

·
Registered
Batmobile
Joined
·
1,085 Posts

 

·
Registered
Joined
·
6 Posts

Thanks! I did order the adapter cable, will let you know how it goes!
 

·
Registered
Joined
·
1 Posts
You'll have to have the light cleared, I did the same thing a while back. There's no problem, just doesn't like being dead. I ended up buying a cable to go from the yamaha connector on ebay and an OBD2 to Bluetooth device. I can monitor all my sensors via the torque pro app now too. I'll see if I can find the links.
Can I clear the check engine light with dynojet power series. I did the same thing too. I took it to a near buy dealer did full check but could not do diagnostics due to my mapping and being locked out. The mapping was done with dynojet so I was hoping I can clear with it also.
 

·
Registered
Batmobile
Joined
·
1,085 Posts
Honestly I have no idea about anything dynojet, I had my bike flashed by Dave pretty much right away and I've loved it ever since. It seems really odd to me that the dealer couldn't get into their own system with the dynojet tune though.
 
1 - 15 of 15 Posts
Top