Yamaha FZ-09 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hey guys, for those that have installed the akra carbon kit - do you have a check engine light on?
My o2 sensor seems to be connected fine, although I did struggle with the install.

Cheers
 

·
Registered
Joined
·
43 Posts
Mine didnt come on after install at all. You may have a damaged O2 sensor especially if you twisted it a lot to unscrew it.

Bite the bullet and take it in to the shops I reckon :(
 

·
Registered
Joined
·
200 Posts
Hey guys, for those that have installed the akra carbon kit - do you have a check engine light on?
My o2 sensor seems to be connected fine, although I did struggle with the install.

Cheers
I had light come on after installing exhaust as O2 sensor plug not fully home (cable run very tight). Dealer cleared at service, fine since.
 

·
Registered
Joined
·
2,954 Posts
Did you happen to turn the key on before connecting the O2 sensor ? That would do it !
 

·
Premium Member
Joined
·
2,873 Posts
So a follow up on this - once i plugged the 02 sensor in properly and went for a decent ride, the check engine light turned itself off and no issues now 👍
Good Sir: A special thanks to you for letting us know the resolution. This will surly be a recurring situation and now an answer is just a click away.
Many of our new members come on the board with a question and after receiving a variety of possible solutions they disappear without closure and leave us wondering. Not so in this case.
 
1 - 9 of 9 Posts
Top