Yamaha FZ-09 Forum banner

1 - 13 of 13 Posts

Registered
Joined
7 Posts
Discussion Starter · #1 ·
I've got a 2017 fz09 engine that im trying to get to turn over it was taken out of a wrecked frame, my intentions for this motor is for it to be put on a buggy frame engine has less than 2k miles on it, i wanna know what all i need to get this baby running I've already bought a new wiring harness and ignition switch im pretty sure i have everything plugged in the right places i have my upright sensor and kickstand sensor and ive made sure there in the right positions and still can't get it to turn over, still a shit ton of stuff thats not plugged into anywhere and im hoping thats where my problems at, my display to lights up but all it says is err and I dont know what to do from this point forward 馃檭 1619980206464747068448951249149.jpg
164481
 

Attachments

Registered
Joined
5,315 Posts
I assume that you can rotate the crank by hand, ie not seized.
 

Registered
Joined
7 Posts
Discussion Starter · #3 ·
Yes I can turn it over by hand, don't have anyway to pull the clutch in other then by pushing on the little lever, also not 100% if I'm even correct on this being the clutch
164484
 

Registered
Joined
896 Posts
You say you have a bunch of things not plugged in. Might just be your clutch switch, whatever plug that is. May need to jump that with a piece of wire.
 

Registered
2016 xsr 900
Joined
773 Posts
Could also be the 'gear' sensor, if the system thinks the bike is in gear it won't crank.
 

Registered
Joined
397 Posts
Do you have an ECU? Perhaps because the engine is not connected to the fuel pump?
 

Registered
Joined
1,012 Posts
What aren't you getting?
Spark, fuel, air?
Should be a simple test especially without the bike frame in the way.
 

Registered
Joined
7 Posts
Discussion Starter · #10 ·
What aren't you getting?
Spark, fuel, air?
Should be a simple test especially without the bike frame in the way.
Well nothing, all I can get the engine to do is light the dash up, I believe it has something to do with all the safety precautions, like upright sensor, kickstand sensor, clutch sensor.
I know the motors not seized, I was trying to start it in gear too, ive fixed that but I'm waiting on a clutch sensor too arrive rn and ill update after it arrives
 

Registered
Joined
7 Posts
Discussion Starter · #11 ·
Could also be the 'gear' sensor, if the system thinks the bike is in gear it won't crank.
That was something I was trying to do, I've got it in neutral now, after I get a clutch sensor ill hopefully have all the safety shit taken care of and ill see what happens
 

Registered
Joined
510 Posts
I do not know your background so I'm going on zero info:

Here are my "Pro Tips":

1. Get service manual. Understand how the systems of the bike, in your case, relating to motor, work.

2. All sensors you have mentioned above have to be accounted for. If one is not reporting the expected status, ECU will say Foxtrot Uniform!

3. This will depend on the final application the motor will be used, but I'm sure all or most sensors above can be bypassed. Mind the safety features of each sensor in order to judge what will be required for the application in hand.

4. Grounding... keep in mind, you do not have a chassis for grounding. It is possible that some of the sensors you DO have right now are just hanging and not grounded, hence why they may not be working.
 
1 - 13 of 13 Posts
Top