Locked ECU, no fix (New Yamaha serial) - Page 3
Close
Login to Your Account
Yamaha FZ-09 Forum

Locked ECU, no fix (New Yamaha serial)

This is a discussion on Locked ECU, no fix (New Yamaha serial) within the XSR900 General Discussion forums, part of the Yamaha XSR900 Cafe Racer Forum category; Originally Posted by JBolt I wanted to pass along a major issue I ran into with sending off my ECU on my 2018 XSR900 to ...

Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34
Like Tree48Likes

Thread: Locked ECU, no fix (New Yamaha serial)

  1. #21
    Senior Member NCost's Avatar
    Member #
    38302
    Join Date
    Aug 2018
    Location
    44830
    Posts
    152
    Quote Originally Posted by JBolt View Post
    I wanted to pass along a major issue I ran into with sending off my ECU on my 2018 XSR900 to get flashed. Purchased the M4 exhaust/ECU flash combo from 2 wheel dyno works and sent off my ECU while I installed the exhaust. When I got it back, it would crank, fire up for a couple seconds with a very weird sounding firing order, then die. After troubleshooting, I was told to return the ECU to them. They then sent me an email stating that I have a new generation of ECU from Yamaha ending with a -70 that the Flash Tune software has a huge glitch with. The ECU is locked and they have no option but to order a new factory ECU for me from Japan which may arrive sometime in June.

    I want to be clear that I am not blaming 2 wheel dynoworks as I have no evidence they did anything wrong, and they are doing what they can to help me out. I am just passing this along because if I well established tuner like them ran into this, there could be other tuners that have the same issue. Be aware if you are sending that serial of ECU out. I only have the info that they passed along to me.

    They stated that Flashtune does not have a fix, so I will unfortunately be running a factory tune with my exhaust for who knows how long which sucks.

    Attachment 152710
    So lets sum up the situation:

    Your bike ran fine and you sent your ECU to be flashed by 2WD. They flashed it and sent it back. Now bike doesn't run. You sent the ECU back to them and then they realize it's a -70 ECU and is locked.
    Had they done due diligence they would have realized this prior to flashing it the first time and sent it back in stock form telling you they can't flash it.
    So they realized THEY bricked it and at least are willing to replace the ECU for you. I give them credit for that, but they shouldn't have run into that problem in the fist place. My .02
    TwoWheelObsession and 93MT09 like this.
    https://designcostello.com/

    2017 Yamaha FZ 09
    2016 BMW FG800GS
    2012 Yamaha FJR
    2009 Yamaha FZ1
    2002 Yamaha RoadStar 1600
    1986 Yamaha FJ1200
    1982 Yamaha YZ 125
    1981 Yamaha Virago 750
    1974 Yamaha MX 125
    1973 Yamaha GTMX 80

  2. #22
    Junior Member JBolt's Avatar
    Member #
    40718
    Join Date
    Jun 2019
    Posts
    8
    Quote Originally Posted by NCost View Post
    So lets sum up the situation:

    Your bike ran fine and you sent your ECU to be flashed by 2WD. They flashed it and sent it back. Now bike doesn't run. You sent the ECU back to them and then they realize it's a -70 ECU and is locked.
    Had they done due diligence they would have realized this prior to flashing it the first time and sent it back in stock form telling you they can't flash it.
    So they realized THEY bricked it and at least are willing to replace the ECU for you. I give them credit for that, but they shouldn't have run into that problem in the fist place. My .02
    Yep. As stated, I don't understand why it occurred or why they weren't aware that map has issues or something. They did inform me when I called to check the status after 4-5 days on a 1 day turn around service about this "new" -70 serial I have that is a bit different and newer, but they did not state anything about it being a problem or there being any risk of this. I feel like by that time something had already happened though and MAYBE I should not have been sent back the messed up ECU in the first place. I only know what they are telling me, so yeah, even if something else is up that they aren't telling me, they are at least making it right. Just sucks making it right makes me miss a huge chunk of riding season here in the northwest on a bike I JUST got.
    Last edited by JBolt; 06-05-2019 at 09:21 AM.

  3. #23
    vcyclenut's Avatar
    Member #
    2695
    Join Date
    Jun 2014
    Location
    fort myers, florida
    Posts
    994
    screen shot shows I flashed one all the way back in September of last year (very bottom of the screen) , so it is not new it is just the newest one


    xsr 70 woolich.jpg
    Attached Images Attached Images  
    JBolt, kevxtx and Jazzboyfunk like this.

  4. Remove Advertisements
    FZ09.org
    Advertisements
     

  5. #24
    Member Wizard1A's Avatar
    Member #
    20089
    Join Date
    Apr 2017
    Location
    San Diego
    Posts
    30
    No issues with the 2017.
    2017 FZ-09; Brilliant White - POWTEC Shorty adjustable levers - OES Frame sliders, fork sliders, rear axle sliders - Tech Spec Tank Grips - Vizi-tec brake light modulator - TST Ind. flush mount indicators (smoke) - TST Industries low mount tail tidy - Akrapovic Ti Full Exhaust - DNA Air filter - Flashed by Vcyclenut

  6. #25
    Member Ron_Luning's Avatar
    Member #
    32537
    Join Date
    Feb 2018
    Location
    Ellicott City, MD
    Posts
    53
    Quote Originally Posted by vcyclenut View Post
    reputable flasher
    Any time I read these 2 words together on a motorcycle forum, it gives me a grin.
    raydeightor and vcyclenut like this.

  7. #26
    vcyclenut's Avatar
    Member #
    2695
    Join Date
    Jun 2014
    Location
    fort myers, florida
    Posts
    994
    Quote Originally Posted by Ron_Luning View Post
    Any time I read these 2 words together on a motorcycle forum, it gives me a grin.
    Its great when people ask me what I do and I say I am a flasher. The hamster on the wheel in their head trying to figure out what I mean is always fun to watch.

  8. #27
    vcyclenut's Avatar
    Member #
    2695
    Join Date
    Jun 2014
    Location
    fort myers, florida
    Posts
    994
    Quote Originally Posted by JBolt View Post
    I wanted to pass along a major issue I ran into with sending off my ECU on my 2018 XSR900 to get flashed. Purchased the M4 exhaust/ECU flash combo from 2 wheel dyno works and sent off my ECU while I installed the exhaust. When I got it back, it would crank, fire up for a couple seconds with a very weird sounding firing order, then die. After troubleshooting, I was told to return the ECU to them. They then sent me an email stating that I have a new generation of ECU from Yamaha ending with a -70 that the Flash Tune software has a huge glitch with. The ECU is locked and they have no option but to order a new factory ECU for me from Japan which may arrive sometime in June.

    I want to be clear that I am not blaming 2 wheel dynoworks as I have no evidence they did anything wrong, and they are doing what they can to help me out. I am just passing this along because if I well established tuner like them ran into this, there could be other tuners that have the same issue. Be aware if you are sending that serial of ECU out. I only have the info that they passed along to me.

    They stated that Flashtune does not have a fix, so I will unfortunately be running a factory tune with my exhaust for who knows how long which sucks.

    Attachment 152710

    are you fixed yet??

  9. #28
    Junior Member JBolt's Avatar
    Member #
    40718
    Join Date
    Jun 2019
    Posts
    8
    Quote Originally Posted by vcyclenut View Post
    are you fixed yet??
    I am! Took a few weeks to get back, and the tune is 90% there by utilizing a general aftermarket exhaust profile. Still got the other good features at least though like 205* fan kick-on, etc... Once it gets more refined I am to send it back in for the new flash. Runs well from what I can tell. I'm just happy to be riding it! Not a fun experience, but hopefully my pain helps prevent others from running into this if Flashtune really did fix this based on my ECU or an unlucky few of us.
    vcyclenut and raydeightor like this.

  10. #29
    Member Playjuryst's Avatar
    Member #
    7417
    Join Date
    May 2016
    Location
    NYC
    Posts
    74

    Locked ECU, no fix (New Yamaha serial)

    Quote Originally Posted by vcyclenut View Post
    are you fixed yet??
    Arf ::tucks tail between legs::

    Glad your bikes back up, Jbolt


    Sent from my iPhone using Tapatalk
    JBolt likes this.

  11. #30
    vcyclenut's Avatar
    Member #
    2695
    Join Date
    Jun 2014
    Location
    fort myers, florida
    Posts
    994
    Quote Originally Posted by JBolt View Post
    I am! Took a few weeks to get back, and the tune is 90% there by utilizing a general aftermarket exhaust profile. Still got the other good features at least though like 205* fan kick-on, etc... Once it gets more refined I am to send it back in for the new flash. Runs well from what I can tell. I'm just happy to be riding it! Not a fun experience, but hopefully my pain helps prevent others from running into this if Flashtune really did fix this based on my ECU or an unlucky few of us.
    glad they got it fixed for you!!
    JBolt likes this.

Page 3 of 4 FirstFirst 1234 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

xsr900 ecu locked

Click on a term to search for related topics.