Turn signals not working -where all to check?
Close
Login to Your Account
Yamaha FZ-09 Forum

Turn signals not working -where all to check?

This is a discussion on Turn signals not working -where all to check? within the Yamaha FZ-09 Guides and How-To's forums, part of the Yamaha FZ-09 Garage category; The turn signals stopped working! Today morning I saw the right turn signal was on. So I switched it off and then I never saw ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Like Tree7Likes

Thread: Turn signals not working -where all to check?

  1. #1
    Senior Member motorock's Avatar
    Member #
    696
    Join Date
    Nov 2013
    Location
    NYC
    Posts
    1,149

    Turn signals not working -where all to check?

    The turn signals stopped working!

    Today morning I saw the right turn signal was on. So I switched it off and then I never saw any of the turn signals work again.

    The running lights up front work. But none of the signals work. Where all should I look? WHich is the fuse for the signals? And how do I check if the flasher has conked off! And if it is the latter, can that be covered by warranty? The bike is barely 1450 miles old!

    Any suggestions?

  2. #2
    Senior Member LehighLuke's Avatar
    Member #
    429
    Join Date
    Oct 2013
    Location
    Philadelphia
    Posts
    1,202
    take it to the dealer and use hand signals.
    -------------------------------------------------------------------
    '14 Liquid Graphite FZ-09 #112....RIP 4/16/14
    '02 YZF-600R -SOLD-
    Yamaha 650 Maxim -1st Bike, RIP-

    help me on my road to recovery: LehighLuke involved in near fatal motorcycle accident

    www.lucastechnical.com
    www.beadbuster.com

  3. #3
    Senior Member FJRider's Avatar
    Member #
    494
    Join Date
    Oct 2013
    Location
    Wisconsin
    Posts
    670
    Check your fuses. You can verify the relay is working if you hear it clicking. It's probably something simple.

  4. Remove Advertisements
    FZ09.org
    Advertisements
     

  5. #4
    Senior Member Roger's Avatar
    Member #
    365
    Join Date
    Sep 2013
    Location
    Middletown, New York
    Posts
    354
    You probably just need a new flasher to check turn your hazard lights on to see if they blink if not its either the fuse or the flasher.
    OWNER: Liquid Graphite FZ - 09
    Current Mods
    Lightbulb upgrade
    Tank protector
    Ram mount
    Quick connect plug
    Spiegler brake lines
    Tank grips

  6. #5
    Senior Member motorock's Avatar
    Member #
    696
    Join Date
    Nov 2013
    Location
    NYC
    Posts
    1,149
    I hear some clicking when I turn the signals on- but sometimes I dont. The light on the dash doesn't flash either.
    The hazards are also not working- the running lights and brake lights work.

    As for the fuse- where is the fuse for the signals? Is it one of the 7.5 ones inside the fuse box?

  7. #6
    Senior Member bobby walnuts's Avatar
    Member #
    102
    Join Date
    Jul 2013
    Posts
    1,806
    does the horn work? if not, it's probably the fuse that's blown.

    signal system fuse is the 7.5a fuse in the right air intake.

  8. #7
    Senior Member motorock's Avatar
    Member #
    696
    Join Date
    Nov 2013
    Location
    NYC
    Posts
    1,149
    The horn works! I checked the fuse- it looked fine but still replaced it and still the turn signals dont work.
    Wondering if the flasher has conked off,

  9. #8
    Senior Member motorock's Avatar
    Member #
    696
    Join Date
    Nov 2013
    Location
    NYC
    Posts
    1,149
    So, I swapped the flasher and nothing! I guess its back to probing wires!...any other tips that could help?
    maryleejayne likes this.

  10. #9
    Senior Member RichBinAZ's Avatar
    Member #
    486
    Join Date
    Oct 2013
    Location
    Mesa AZ, USA
    Posts
    551
    Sounds like you are down to the switch itself (handlebar) or the wiring. - Although if the hazards don't work (different switch) - sounds like wiring. A lot of connections are made in the back of the speedo, anything there??

    But don't take my advice, I'm bad at diagnosing electrical problems. At this point I would take it in for them to put their electrical sleuth on it - if you trust the dealer of course... I'm getting this unsaid vibe that you don't???
    RichBinAZ
    2014 FZ-09 + Stoltec Shock
    2001 Triumph Bonneville
    1991 GSX1100G (the shafty Bandit)

  11. #10
    Senior Member JustWantToRide's Avatar
    Member #
    902
    Join Date
    Dec 2013
    Location
    Austin, Texas
    Posts
    962
    I suspect the switch. Have you washed it with a high pressure hose? If so - you may have gotten water into the switch or the connectors. Spray into the switchgear with electrical cleaner (protect your tank), wait a while and try it again. Take the switch apart and jump the wires to make the turn signals go. If nothing then trace the wires back and make sure the connectors are seated properly where it connects to the main wiring harness. Other than that - the nect most likely is a pinched/cut/faulty wire in the wiring harness. You really want a dealer to take it up from there.

    If you changed handlebars or rerouted wires then the connector could have been disturbed, or a wire could have been pinched. If you lifted the tank then it could have disconnected or pinched them...

    What mods/adjustments have you done to your bike that might have disturbed the wires?

Page 1 of 3 123 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. front turn signals
    By darksyde69 in forum FZ-09 Gear & Accessories
    Replies: 35
    Last Post: 01-14-2015, 03:19 PM
  2. Want to find turn signals
    By KyleB in forum Parts for Sale / Wanted
    Replies: 11
    Last Post: 02-25-2014, 08:53 PM
  3. How do you slow down turn signals
    By zloikish in forum FZ-09 General Discussion
    Replies: 5
    Last Post: 01-01-2014, 06:18 PM
  4. Turn signals
    By EdVR in forum FZ-09 General Discussion
    Replies: 13
    Last Post: 12-09-2013, 10:07 AM
  5. Aftermarket Turn Signals
    By Ddavis4035 in forum FZ-09 General Discussion
    Replies: 3
    Last Post: 11-03-2013, 02:33 PM

Search tags for this page

2016 yamaha fz09 blinker fuse
,
2016 yamaha r3 turn signal fuse
,
fz 09 fuse box
,
fz 09 signals not working
,
fz 750 turn signals not working
,
fz09 flashers stopped working
,
fz09 fuze box
,
fz09 signal fuse
,

fz09 turn signal fuse

,

how to access fuse box fz-09

,
mt07 indicator not ighting up
,

wire connection for fz handle bar switches

,

yamaha fz 09 blinker fuse

,
yamaha fz s speedometer not working
Click on a term to search for related topics.