"Oil" light comes on and off.....anybody has opinion about it?
Close
Login to Your Account
Yamaha FZ-09 Forum

"Oil" light comes on and off.....anybody has opinion about it?

This is a discussion on "Oil" light comes on and off.....anybody has opinion about it? within the XSR900 Common Problems/Issues forums, part of the Yamaha XSR900 Cafe Racer Forum category; Hi, I have a question and your help is greatly appreciated !!! The bike is 2017 XSR900 Oil light comes on and off after oil ...

Results 1 to 7 of 7
Like Tree5Likes
  • 4 Post By 1wheelsenuf
  • 1 Post By dcpppf

Thread: "Oil" light comes on and off.....anybody has opinion about it?

  1. #1
    Junior Member XSR847's Avatar
    Member #
    39364
    Join Date
    Jan 2019
    Posts
    20

    "Oil" light comes on and off.....anybody has opinion about it?

    Hi, I have a question and your help is greatly appreciated !!! The bike is 2017 XSR900

    Oil light comes on and off after oil change when I push the bike a little bit, but not all the time. Oil level is at 3/4. The manual says use 10W40 or 10W50 JASO MA. Since the summer has come in Vegas already I have switched from 10W40 to 10W50 for the hot weather, but is JASO MA2. I have wonder if that might be a problem, but it shouldn't. I have read for the same problem on different forum, but only one person has replied to the post " OIL level should be to the max border line" - witch doesn't sound right to me. I have had 11 bikes for 10 years and did lot's of oil changes always at 3/4 level and never experienced this problem before. Does anybody have an advice?

    Thank you in advance!

  2. #2
    Junior Member 1wheelsenuf's Avatar
    Member #
    40092
    Join Date
    Apr 2019
    Posts
    14
    As with most yamahas it is a level sensor, put more oil in as the cp3 motor is quite sensitive to oil levels.
    dcpppf, astcyr, Moto26 and 1 others like this.

  3. #3
    Senior Member dcpppf's Avatar
    Member #
    2879
    Join Date
    Jul 2014
    Location
    KC, KS/MO
    Posts
    855
    Quote Originally Posted by 1wheelsenuf View Post
    As with most yamahas it is a level sensor, put more oil in as the cp3 motor is quite sensitive to oil levels.
    ^ agreed. I've seen a few threads these past couple of months on this topic. Conclusion is just that possibly you didn't have the bike "perfectly" vertical and ended up under filling per the site glass just a smidge. And yes these bikes have an oil level sensor (not pressure) so it's just thinking you're a bit low.
    Moto26 likes this.
    Mods: under seat USB charger, complete OES slider/spool set, evotech rad guard, yoshimura FE, barracuda freccia turn signals (front and back), ASV shorty levers (black w/ gold adjusters), puig dark tinted sport screen, APE CCT, Tripage LED Pegs, Ohlin's rear shock, Akra Ti, gold/smoked stainless brake lines (front and back), PowerMadd hand guards

  4. Remove Advertisements
    FZ09.org
    Advertisements
     

  5. #4
    Senior Member blkbrd's Avatar
    Member #
    5442
    Join Date
    Jun 2015
    Location
    Midland, ON
    Posts
    1,363
    Put 3 qts in after every oil and filter change. You will never see the light again.

    Sent from my SM-G950W using Tapatalk
    2015 Matte Grey FZ-09 --- Oxford Heated Grips --- Spiegler S/S Brake lines --- OES Frame Sliders --- OES Front Axle Sliders --- GYTR Rad Guard --- GYTR Windscreen --- Racetech Gold Valves --- Racetech Fork Springs --- ZX6R Rear Shock --- Rizoma Action LED Turn Signals --- Tripage Gold LED Headlamp --- E-Bay Pazzo Knockoff Levers --- Termignoni Carbon Exhaust --- Power Commander 5 --- Yoshimura Fender Eliminator --- Ivan's ECU Flash --- Shad Comfort Seat -- GYTR Quick Shifter

  6. #5
    Junior Member 1wheelsenuf's Avatar
    Member #
    40092
    Join Date
    Apr 2019
    Posts
    14
    My last bike (FZS1000/FZ1 to you septics) had to be filled to the top of the sight glass otherwise the oil light would flicker under hard braking/acceleration

  7. #6
    Junior Member XSR847's Avatar
    Member #
    39364
    Join Date
    Jan 2019
    Posts
    20

    Thumbs up

    Quote Originally Posted by 1wheelsenuf View Post
    As with most yamahas it is a level sensor, put more oil in as the cp3 motor is quite sensitive to oil levels.
    Thank you guys, seems like everybody is on the same page, I will fill it up.

  8. #7
    Senior Member XSR-900's Avatar
    Member #
    10762
    Join Date
    Aug 2016
    Location
    Seattle WA
    Posts
    606
    Quote Originally Posted by XSR847 View Post
    Thank you guys, seems like everybody is on the same page, I will fill it up.
    Yep, the very top of the sight glass is the FULL line. That's where I run mine and I never see an oil level warning light. JASO MA2 has nothing to do with it.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. oil light comes on shortly after startup
    By tatman in forum FZ-09 General Discussion
    Replies: 14
    Last Post: 06-16-2019, 03:11 AM
  2. Oil Light Comes On
    By WebbyRides in forum FZ-09 General Discussion
    Replies: 30
    Last Post: 09-30-2017, 03:06 PM
  3. Replies: 25
    Last Post: 06-18-2017, 03:30 PM
  4. Fz09 CEL comes on and off.
    By Yamaholic1155 in forum Yamaha FZ-09 Common Problems/Issues
    Replies: 5
    Last Post: 02-18-2017, 10:22 AM
  5. Oil light- anybody else have this happen?
    By Speedbird in forum Yamaha FZ-09 Common Problems/Issues
    Replies: 22
    Last Post: 08-24-2015, 07:48 PM